Depends on how and why I'm reading the code aloud.
I very rarely speak the cryptic incantations of source code.
Normally I dislike variables with names like 'ptr'. I would prefer a descriptive name optionally with a Hungarian-style prefix. pCurrentObject, nearest, pBody, but not ptr.
Sometimes I would one use and sometimes another. If "ptr" was on its own I might call it "pointer", or I might throw in some vowel-like sounds approaching "peter" or "putter" or maybe "pee tee are", depending on who I was explaining it to and why.
There are situations where general understanding is more important than the specific terms and labels. If I were explaining the code in a less technical review I might change "pCurrentObject" to "current object pointer", and that's where I'd change "ptr" to "pointer", I'd change "idx" to "index", "char" becomes "character", and so on. In that scenario the key feature is the concept rather than literal accuracy.
In other scenarios where I am working through code to find a defect that may include subtle naming issues, I would not adjust names. When the exact details of the variable names was important in the meeting I would call pCurrentObject as "Pee Current Object", ptr as either "peter/putter" or "pee tee are", and idx as "eye dee ex" or "eye dex", and "char" remains "char" like blackened meat.